diff setup.py @ 0:6275272ebcbc draft

planemo upload commit 9b152b4a900a8cd70df992da881c7e3fa00d4e4c-dirty
author cstrittmatter
date Thu, 21 Dec 2017 12:45:31 -0500
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/setup.py	Thu Dec 21 12:45:31 2017 -0500
@@ -0,0 +1,19 @@
+
+from setuptools import setup
+
+setup(
+    name = "seqsero2",
+    version = "2.0",
+    author = "DengLab",
+    author_email = "seqsero@gmail.com",
+    description = ("Serotyping for Salmonella."),
+    license = "GPL-2.0",
+    keywords = "salmonella",
+    url = "https://github.com/charesredhat/SeqSero2",
+    packages=['seqsero2'],
+    scripts=['scripts/SeqSero2.py'],
+     entry_points={
+        'console_scripts': ['SeqSero2 = seqsero2.SeqSero2:main']
+    },
+    package_dir = {'seqsero2': 'scripts'}
+)