diff env/lib/python3.7/site-packages/webencodings/mklabels.py @ 5:9b1c78e6ba9c draft default tip

"planemo upload commit 6c0a8142489327ece472c84e558c47da711a9142"
author shellac
date Mon, 01 Jun 2020 08:59:25 -0400
parents 79f47841a781
children
line wrap: on
line diff
--- a/env/lib/python3.7/site-packages/webencodings/mklabels.py	Thu May 14 16:47:39 2020 -0400
+++ /dev/null	Thu Jan 01 00:00:00 1970 +0000
@@ -1,59 +0,0 @@
-"""
-
-    webencodings.mklabels
-    ~~~~~~~~~~~~~~~~~~~~~
-
-    Regenarate the webencodings.labels module.
-
-    :copyright: Copyright 2012 by Simon Sapin
-    :license: BSD, see LICENSE for details.
-
-"""
-
-import json
-try:
-    from urllib import urlopen
-except ImportError:
-    from urllib.request import urlopen
-
-
-def assert_lower(string):
-    assert string == string.lower()
-    return string
-
-
-def generate(url):
-    parts = ['''\
-"""
-
-    webencodings.labels
-    ~~~~~~~~~~~~~~~~~~~
-
-    Map encoding labels to their name.
-
-    :copyright: Copyright 2012 by Simon Sapin
-    :license: BSD, see LICENSE for details.
-
-"""
-
-# XXX Do not edit!
-# This file is automatically generated by mklabels.py
-
-LABELS = {
-''']
-    labels = [
-        (repr(assert_lower(label)).lstrip('u'),
-         repr(encoding['name']).lstrip('u'))
-        for category in json.loads(urlopen(url).read().decode('ascii'))
-        for encoding in category['encodings']
-        for label in encoding['labels']]
-    max_len = max(len(label) for label, name in labels)
-    parts.extend(
-        '    %s:%s %s,\n' % (label, ' ' * (max_len - len(label)), name)
-        for label, name in labels)
-    parts.append('}')
-    return ''.join(parts)
-
-
-if __name__ == '__main__':
-    print(generate('http://encoding.spec.whatwg.org/encodings.json'))